httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject DO NOT REPLY [Bug 49719] New: authnz_ldap_module on Apache2.2.16 gives 500 Internal Server Error
Date Fri, 06 Aug 2010 19:53:26 GMT

           Summary: authnz_ldap_module on Apache2.2.16 gives 500 Internal
                    Server Error
           Product: Apache httpd-2
           Version: 2.2.15
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: major
          Priority: P2
         Component: mod_authz_ldap

I am running Apache2.2.16 on a Solaris10 server. I am not using SSL. The part
of my httpd.conf file is:

LoadModule rewrite_module modules/
LoadModule authnz_ldap_module modules/
LoadModule ldap_module modules/

    <Directory "/usr2/apache2.2.16/testdir">
        AuthType Basic
        AuthBasicProvider ldap
        AuthName "Directory Users"
        #AuthUserFile /dev/null
        AuthLDAPURL ldap://,ou=intranet,dc=xxxx,dc=
        AuthzLDAPAuthoritative Off
        #Satisfy Any
        Require valid-user

The website comes up. But access to http://xxx.xom/testdir prompts for LDAP
authentication but returns 500 Internal Server Error on the browser. The server
error logs have no further information.I used openldap-2.4.22-sol10-sparc-local

I am trying to upgrade from Apache 1.3.28 to Apache 2.2.16. The LDAP
authentication works on the same server in Apache 1.3.28.
Could anyone please correct me if I am making any mistake in the syntax above?

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message