httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 49239] New: Apache mod_ssl gives coredump with openssl 0.9.8
Date Sat, 01 May 2010 06:16:13 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=49239

           Summary: Apache mod_ssl gives coredump with openssl 0.9.8
           Product: Apache httpd-2
           Version: 2.2.8
          Platform: HP
        OS/Version: HP-UX
            Status: NEW
          Severity: blocker
          Priority: P2
         Component: mod_ssl
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: matty.rnld@gmail.com


Hi,

Iam building apache on a HP-UX system (IA 32 bits).

Iam facing issues to start  apache (mod_ssl enabled) with openssl 0.9.8 libs.

when i try to start apache with mod_ssl apache doesn't start at all giving
coredump.

Below is the stack trace of the core generated:

#0  0x60000000c026bee0:0 in free+0xc0 () from /usr/lib/hpux32/libc.so.1

#1  0x60000000c1cd61c0:0 in CRYPTO_free+0x80 ()

   from /usr/lib/hpux32/libssl.so.1

#2  0x60000000c1cdbfd0:0 in sk_pop_free+0xd0 ()

   from /usr/lib/hpux32/libssl.so.1

#3  0x60000000c147d150:0 in SSL_CTX_use_certificate_chain+0x110 ()

   from /usr/local/apache32/modules/mod_ssl.so

#4  0x60000000c144ee20:0 in <unknown_procedure> + 0x210 ()

   from /usr/local/apache32/modules/mod_ssl.so

#5  0x60000000c144fa00:0 in <unknown_procedure> + 0x260 ()

   from /usr/local/apache32/modules/mod_ssl.so

#6  0x60000000c1451da0:0 in <unknown_procedure> + 0xf0 ()

   from /usr/local/apache32/modules/mod_ssl.so

#7  0x60000000c144d6d0:0 in ssl_init_ConfigureServer+0x130 ()

   from /usr/local/apache32/modules/mod_ssl.so

#8  0x60000000c144caf0:0 in ssl_init_Module+0x520 ()

   from /usr/local/apache32/modules/mod_ssl.so

#9  0x408cd80:0 in ap_run_post_config () at config.c:96

#10 0x404abb0:0 in main () at main.c:685

(gdb) where

#0  0x60000000c026bee0:0 in free+0xc0 () from /usr/lib/hpux32/libc.so.1

#1  0x60000000c1cd61c0:0 in CRYPTO_free+0x80 ()

   from /usr/lib/hpux32/libssl.so.1

#2  0x60000000c1cdbfd0:0 in sk_pop_free+0xd0 ()

   from /usr/lib/hpux32/libssl.so.1

#3  0x60000000c147d150:0 in SSL_CTX_use_certificate_chain+0x110 ()

   from /usr/local/apache32/modules/mod_ssl.so

#4  0x60000000c144ee20:0 in <unknown_procedure> + 0x210 ()

   from /usr/local/apache32/modules/mod_ssl.so

#5  0x60000000c144fa00:0 in <unknown_procedure> + 0x260 ()

   from /usr/local/apache32/modules/mod_ssl.so

#6  0x60000000c1451da0:0 in <unknown_procedure> + 0xf0 ()

   from /usr/local/apache32/modules/mod_ssl.so

#7  0x60000000c144d6d0:0 in ssl_init_ConfigureServer+0x130 ()

   from /usr/local/apache32/modules/mod_ssl.so

#8  0x60000000c144caf0:0 in ssl_init_Module+0x520 ()

   from /usr/local/apache32/modules/mod_ssl.so

#9  0x408cd80:0 in ap_run_post_config () at config.c:96

#10 0x404abb0:0 in main () at main.c:685

(gdb)


I have also tried with the latest mod_ssl that comes with apache 2.2.15. But
still the same issue.

Please help.

Regards,
Matty

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message