httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 48819] New: After users login on the web page, the page does not show they are logged in
Date Thu, 25 Feb 2010 21:00:07 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=48819

           Summary: After users login on the web page, the page does not
                    show they are logged in
           Product: Apache httpd-2
           Version: 2.2.14
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_proxy_http
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: ruiyuan_jiang@liz.com


The setup was:

BlueCoat reverse proxy server --> HPUX 11.23, Apache v2.2.8, Tomcat 5.5 -->
Oracle DB.

Before we upgraded to HPUX 11.23, Apache v2.2.8, Tomcat 5.5 in above setup, we
used HPUX 11.11, Apache v2.0.59, Tomcat 5.5 with mod_ajp (mod_jk) no problem.
The Apache on HPUX 11.11 has multiple virtual servers. I use two virtual
servers to explain the problem. One virtual server strictly served local html
static web pages. Another virtual server is Apache mod_jk redirected traffic to
Tomcat AJP port. 
We migrated to HPUX 11.23, Apache v2.2.8, Tomcat 5.5. After running for several
days, Apache stopped to redirect traffic to Tomcat. Meanwhile the Apache
virtual server served static html web pages no problem. We first thought the
problem is on Tomcat, restarted Tomcat did not help. After restarted Apache,
the problem fixed and it ran for several days then the problem happened again
and needed to restart Apache again. I then downgraded Apache to v2.0.59 on HPUX
11.23 and the problem went away. The only change here is the Apache version and
its httpd.conf file. I called HP support but no help. The latest version of
Apache being compiled by HP is 2.2.8.

The new setup after above setup is:

Solaris 10, Apache v2.2.14 reverse proxy --> HPUX 11.23, Apache v2.0.59, Tomcat
5.5 --> Oracle DB

Here the change is replacing BlueCoat proxy to Solaris. HPUX server stays the
same except Apache being downgraded as the problem described above.

The web pages from multiple virtual servers have user login pages from Tomcat.
After users logged in to the web server, the server does not show the user has
logged. After the user click F5 to refresh the web page, the web page shows the
user is logged in. The same happened when the users logged out from the web
servers. After downgraded Apache on Solaris reverse proxy from v2.2.14 to
v2.0.59, the problem went away. The web page shows the user logged in
correctly. The problem happens on all my web servers. 

On HPUX 11.23 server, we use mod_ajp (mod_jk) to redirect traffic from Apache
to Tomcat AJP which are on the same host.
On Solaris 10 Apache reverse proxy, we use mod_proxy, mod_proxy_http. 
The traffic between HPUX with either front BlueCoat or Solaris is http. 
On my Solaris proxy server, the proxypass and proxyreversepass of one of the
virtualhost are:

     ProxyPass /       http://www.loveisnotabuse.com/
     ProxyPassReverse /        http://www.loveisnotabuse.com/

The Apaches used are compiled by either by HP or Internet although I could. The
changes on Apache side are only httpd.conf or httpd-vhosts.conf.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message