httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 48486] New: ./configure --enable-authnz_ldap; fails
Date Tue, 05 Jan 2010 09:41:34 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=48486

           Summary: ./configure --enable-authnz_ldap; fails
           Product: Apache httpd-2
           Version: 2.2.14
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: blocker
          Priority: P2
         Component: mod_authz_ldap
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: csimms@smart421.com


I have installed openldap-2.4.19 and am trying to install httpd-2.2.14 with the
modules enable-authnz_ldap and enable-ssl.

runing ./config.nice
"./configure" \
"--prefix=/usr/local/apache2" \
"--with-included-apr" \
"--enable-so" \
"--enable-ssl" \
"--enable-mods-shared=all" \
"--with-ssl=/usr/local/openssl" \
"--with-ldap" \
"--enable-ldap" \
"--enable-authnz_ldap" \
"--with-ldap-lib=/usr/local/lib" \
"--with-ldap-include=/usr/local/include" \

get the following error
checking for ldap support...
  setting APRUTIL_INCLUDES to "-I/usr/local/include"
  setting APRUTIL_LDFLAGS to "-L/usr/local/lib"
checking for ldap_init in -lldap50... no
checking for ldap_init in -lldapssl41... no
checking for ldap_init in -lldapssl40... no
checking for ldap_init in -lldapssl30... no
checking for ldap_init in -lldapssl20... no
checking for ldap_init in -lldapsdk... no
checking for ldap_init in -lldapsdk... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
checking for ldap_init in -lldap... no
configure: error: could not find an LDAP library
configure failed for srclib/apr-util


I have entered this as a bug in desperation. I have googled this problem but
found no resolution. I have also entered this in apache forums but have had no
response. I am hoping that the apache developers can provide some help.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message