httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 48388] New: mod proxy disabling workers after a single error
Date Mon, 14 Dec 2009 20:28:28 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=48388

           Summary: mod proxy disabling workers after a single error
           Product: Apache httpd-2
           Version: 2.2.14
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P2
         Component: mod_proxy
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: cvaldivia@gmail.com


Created an attachment (id=24706)
 --> (https://issues.apache.org/bugzilla/attachment.cgi?id=24706)
Error log filtered

We are experiencing intermittent "connect timeout" errors. The remote
service is really "ok", but it still results in the worker being
disabled.

Error Log:(more in attach)

[error] ap_proxy_connect_backend disabling worker for (192.168.5.17)


We have 1 balancer + 10 apache's workers

My config:

<VirtualHost *>
 SetEnv force-proxy-request-1.0 1
 SetEnv proxy-nokeepalive 1

 ProxyRequests Off
 <Proxy *>
   Order deny,allow
   Allow from all
 </Proxy>

ProxyPass /balancer-manager !
ProxyPass / balancer://mycluster/

 ProxyPassReverse / http://192.168.5.11/
 ProxyPassReverse / http://192.168.5.12/
 ProxyPassReverse / http://192.168.5.14/
 ProxyPassReverse / http://192.168.5.15/
 ProxyPassReverse / http://192.168.5.16/
 ProxyPassReverse / http://192.168.5.17/
 ProxyPassReverse / http://192.168.5.18/
 ProxyPassReverse / http://192.168.5.19/
 ProxyPassReverse / http://192.168.5.110/
 ProxyPassReverse / http://192.168.5.111/

<Proxy balancer://mycluster>

   BalancerMember http://192.168.5.11 route=w1 loadfactor=39
   BalancerMember http://192.168.5.12 route=w2 loadfactor=39
   BalancerMember http://192.168.5.14 route=w4 loadfactor=39
   BalancerMember http://192.168.5.15 route=w5 loadfactor=55
   BalancerMember http://192.168.5.16 route=w6 loadfactor=55
   BalancerMember http://192.168.5.17 route=w7 loadfactor=55
   BalancerMember http://192.168.5.18 route=w8 loadfactor=55
   BalancerMember http://192.168.5.19 route=w9 loadfactor=75
   BalancerMember http://192.168.5.110 route=w10 loadfactor=50
   BalancerMember http://192.168.5.111 route=w11 loadfactor=80

 </Proxy>

</VirtualHost>

All servers are in datacenter with 1gb cisco switch and 10/100 internet
bandwidth.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message