httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29744] CONNECT does not work over existing SSL connection
Date Tue, 01 Dec 2009 06:03:35 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=29744

--- Comment #101 from Kevin Croft <krcroft@gmail.com> 2009-11-30 22:03:28 UTC ---
(In reply to comment #100)
> > 
> > Have you tried applying this patch to the 2.2.14 sources?
> >
> > # wget -O - http://apache.mirror.rafal.ca/httpd/httpd-2.2.14.tar.bz2 | tar jx
> > # cd httpd-2.2.14/modules/proxy
> > # curl https://issues.apache.org/bugzilla/attachment.cgi?id=24615 | patch -p1
> > --verbose
> >
> 
> I have double-checked it -- it works fine with Win32 sources.
> 
> unzip httpd-2.2.14-win32-src.zip 
> cd httpd-2.2.14\modules\proxy  
> patch -p1 <mod_proxy_connect.patch 
> 
> patching file mod_proxy_connect.c
> 
> The resulting file is identical to my modified version, so the patch worked. 
> 
> It could be the end-of-line thing, GNU patch.exe for Windows insists on line
> endings to be /r/n, so this is what went into the patch file. I don't have a
> Linux instance handy to check this.

Ivan, that was it. Converted the patch using 'dos2unix', and it applies cleanly
to the generic sources httpd-2.2.14.tar.bz2. Thanks again for the patch, and
sorry for the false alarm!

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message