httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 48056] submitting a multipart form over http containing a text field with the string "poste" results in a timeout on apache
Date Mon, 02 Nov 2009 16:52:49 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=48056

zeetaartpurf@yahoo.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEEDINFO                    |NEW

--- Comment #10 from zeetaartpurf@yahoo.com 2009-11-02 08:52:48 UTC ---
I am not using mod_security, I have even used a default installation of apache
without any changes to the configuration, or without any extra modules to
ensure this issue wasn't related to any external applications, or to any
configuration settings.


When tunneling a working request through a TCP monitor, I send the request:



POST /test-apache/submit2.html HTTP/1.1
Host: atmire.com
Accept:
application/xml,application/xhtml+xml,text/html;q=0.9,text/plain;q=0.8,image/png,*/*;q=0.5
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_1; nl-nl)
AppleWebKit/531.9 (KHTML, like Gecko) Version/4.0.3 Safari/531.9
Origin: http://localhost:5555
Content-Type: multipart/form-data;
boundary=----WebKitFormBoundaryVyCKgwIrA86n1Acg
Referer: http://localhost:5555/test-apache/submit2.html
Accept-Language: nl-nl
Accept-Encoding: gzip, deflate
Cookie:
__utma=111872281.626312053016873200.1229939867.1255558105.1256668835.15;
__utmz=111872281.1245708531.10.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)
Content-Length: 393
Connection: keep-alive

------WebKitFormBoundaryVyCKgwIrA86n1Acg
Content-Disposition: form-data; name="dc_title"

testing with a working page
------WebKitFormBoundaryVyCKgwIrA86n1Acg
Content-Disposition: form-data; name="bitstream_file_type5_file5"; filename=""


------WebKitFormBoundaryVyCKgwIrA86n1Acg
Content-Disposition: form-data; name="submit"

click me
------WebKitFormBoundaryVyCKgwIrA86n1Acg--



And I receive the response:



HTTP/1.1 200 OK
Date: Mon, 02 Nov 2009 16:42:44 GMT
Server: Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.7a DAV/2 SVN/1.6.5
Last-Modified: Mon, 26 Oct 2009 12:35:20 GMT
ETag: "38f934-214-476d5cb6ef200"
Accept-Ranges: bytes
Content-Length: 532
Keep-Alive: timeout=5, max=100
Connection: Keep-Alive
Content-Type: text/html

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
"http://info.togather.eu/togather-test/DTD/xhtml1-transitional.dtd">

<html>
    <head>
    </head>


    <body  id="body" class="body">

<div id="wrapper">


  <form action="submit2.html" method="post" name="edit_metadata"
enctype="multipart/form-data">

<input type="text" name="dc_title" value="poste"/>

<input type="file" name="bitstream_file_type5_file5"/>
<input type="submit" name="submit" value="click me"/>

    </form>

        </div> 

</body>
</html>



Which is simply a display of the test page.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message