httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 47807] New: Proxy dialog error with Apache 2.2.13
Date Wed, 09 Sep 2009 09:47:36 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=47807

           Summary: Proxy dialog error with Apache 2.2.13
           Product: Apache httpd-2
           Version: 2.2.13
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_proxy_balancer
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: sebastien.bilbeau@univ-rennes1.fr


--- Comment #0 from S <sebastien.bilbeau@univ-rennes1.fr> 2009-09-09 02:47:33 PDT ---
Since we have upgrade lot of our frontend server in version 2.2.13 we have an
issue with mod_proxy_balancer or mod_proxy_ajp.

In our logs we can see this message :
httpd[17077]: [error] proxy: dialog to 129.***.***.***:9554 (jent2.****.fr)
failed
httpd[29288]: [error] proxy: dialog to 129.***.***.***:9554 (jent5.****.fr)
failed
httpd[10466]: [error] proxy: dialog to 129.***.***.***:9554 (jent5.****.fr)
failed
httpd[28229]: [error] proxy: dialog to 129.***.***.***:9554 (jent2.****.fr)
failed
httpd[29287]: [error] proxy: dialog to 129.***.***.***:9554 (jent1.****.fr)
failed
httpd[17539]: [error] proxy: dialog to 129.***.***.***:9554 (jent3.****.fr)
failed
httpd[28229]: [error] proxy: dialog to 129.***.***.***:9554 (jent1.****.fr)
failed

All five backend server are under Tomcat 5.5.27.

Apache configuration :

<VirtualHost 129.***.***.***:80>
    ServerName ent.******.fr
    VirtualDocumentRoot /dev/null
    # Balancing
    ProxyPass /balancer-manager !
    ProxyPass / balancer://mycluster/ stickysession=JSESSIONID
    <Proxy balancer://mycluster>
        BalancerMember ajp://129.***.***.***:9554 min=0 max=100 smax=50 ttl=10
route=ent1 timeout=60 loadfactor=100
        BalancerMember ajp://129.***.***.***:9554 min=0 max=100 smax=50 ttl=10
route=ent2 timeout=60 loadfactor=100
        BalancerMember ajp://129.***.***.***:9554 min=0 max=100 smax=50 ttl=10
route=ent3 timeout=60 loadfactor=100
        BalancerMember ajp://129.***.***.***:9554 min=0 max=100 smax=50 ttl=10
route=ent4 timeout=60 loadfactor=100
        BalancerMember ajp://129.***.***.***:9554 min=0 max=100 smax=50 ttl=10
route=ent5 timeout=60 loadfactor=100
    </Proxy>
</VirtualHost>

To fix this issue, we just come back to the 2.2.11 version ...

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message