httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 47370] New: Apache service crashing
Date Tue, 16 Jun 2009 00:27:51 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=47370

           Summary: Apache service crashing
           Product: Apache httpd-2
           Version: 2.2.11
          Platform: PC
        OS/Version: Windows XP
            Status: UNCONFIRMED
          Severity: major
          Priority: P1
         Component: All
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: frankspooner@hotmail.com


I have installed the following on a windows XP(sp3- latest patches) machine...

Apache V2.2.11
PHP 5.2.9-2
phpMyAdmin 2.11.7.1
MySQL 5.1.35

I am starting Apache as a Windows Service.  The system on which the above
components are installed is for web development, so they are contained in an
environment on which Visual Studio 2008 is also installed.  The apache httpd
process starts normally and seeminlgy serves pages pretty much as I expect,
including pages containing PHP code.

When I attempt to login to phpMyAdmin, immediately after I submit my username
and passowrd, I get the following message from the Visual Studio JIT debugger:

An unhandled win32 exception occurred in httpd [3056]

When I click on "OK" a new apache process spawns.  As before, the new process
delivers pages as I'd expect, however, when I login to phpmyadmin, I get the
above message again.

I have enabled about as much logging as I can muster, and I'm surprised at the
lack of detail I find.   The only information I see of any use is from apache,
which seems to fail and restart a process. Nonetheless, I would not have
expected the apache service to fail in this manner.

Windows Event logs: no entries.

PHP error log: no entries.

Apache error log:
[Tue Jun 16 09:38:11 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jun 16 09:38:11 2009] [notice] Parent: Created child process 1356
[Tue Jun 16 09:38:11 2009] [notice] Child 1356: Child process is running
[Tue Jun 16 09:38:11 2009] [info] Parent: Duplicating socket 200 and sending it
to child process 1356
[Tue Jun 16 09:38:11 2009] [notice] Child 1356: Acquired the start mutex.
[Tue Jun 16 09:38:11 2009] [notice] Child 1356: Starting 64 worker threads.
[Tue Jun 16 09:38:11 2009] [notice] Child 1356: Starting thread to listen on
port 80.
[Tue Jun 16 09:39:39 2009] [notice] Parent: Received shutdown signal --
Shutting down the server.
[Tue Jun 16 09:39:39 2009] [notice] Child 1356: Exit event signaled. Child
process is ending.
[Tue Jun 16 09:39:40 2009] [info] Child 1356: Accept thread exiting.
[Tue Jun 16 09:39:40 2009] [notice] Child 1356: Released the start mutex
[Tue Jun 16 09:39:40 2009] [info] Child 1356: 64 threads blocked on the
completion port
[Tue Jun 16 09:39:41 2009] [notice] Child 1356: All worker threads have exited.
[Tue Jun 16 09:39:41 2009] [notice] Child 1356: Child process is exiting
[Tue Jun 16 09:39:41 2009] [notice] Parent: Child process exited successfully.
[Tue Jun 16 09:39:41 2009] [info] removed PID file C:/web/Apache/logs/httpd.pid
(pid=364)
[Tue Jun 16 09:58:32 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-2
configured -- resuming normal operations
[Tue Jun 16 09:58:32 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jun 16 09:58:32 2009] [notice] Parent: Created child process 3056
[Tue Jun 16 09:58:33 2009] [notice] Child 3056: Child process is running
[Tue Jun 16 09:58:33 2009] [info] Parent: Duplicating socket 208 and sending it
to child process 3056
[Tue Jun 16 09:58:33 2009] [notice] Child 3056: Acquired the start mutex.
[Tue Jun 16 09:58:33 2009] [notice] Child 3056: Starting 64 worker threads.
[Tue Jun 16 09:58:33 2009] [notice] Child 3056: Starting thread to listen on
port 80.
[Tue Jun 16 10:01:38 2009] [error] [client 127.0.0.1] script
'C:/web/http/main.php' not found or unable to stat
[Tue Jun 16 10:08:46 2009] [notice] Parent: child process exited with status 0
-- Restarting.
[Tue Jun 16 10:08:46 2009] [notice] Apache/2.2.11 (Win32) PHP/5.2.9-2
configured -- resuming normal operations
[Tue Jun 16 10:08:46 2009] [notice] Server built: Dec 10 2008 00:10:06
[Tue Jun 16 10:08:46 2009] [notice] Parent: Created child process 1716
[Tue Jun 16 10:08:46 2009] [notice] Child 1716: Child process is running
[Tue Jun 16 10:08:46 2009] [info] Parent: Duplicating socket 208 and sending it
to child process 1716
[Tue Jun 16 10:08:46 2009] [notice] Child 1716: Acquired the start mutex.
[Tue Jun 16 10:08:46 2009] [notice] Child 1716: Starting 64 worker threads.
[Tue Jun 16 10:08:46 2009] [notice] Child 1716: Starting thread to listen on
port 80.

I have tries reinstalling the packages with MSI installers and from the ZIP
archives, however, I get the same result.

Any help would be gratefully received.

regards,
    Roger

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message