httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 47329] SSLCADNRequest* & SSLCACertificate* silently do not work with 'Trusted' certificates
Date Thu, 25 Jun 2009 12:34:07 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=47329





--- Comment #4 from tlhackque@yahoo.com  2009-06-25 05:34:03 PST ---
Thanks, that's progress:

I commented-out SSLCADNRequestFile (leaving it to default to
SSLCACertificateFile, which has the trust).

Now get these errors, and httpd doesn't start:

[Thu Jun 25 08:08:12 2009] [error] SSL Library Error: 151441516
error:0906D06C:PEM routines:PEM_read_bio:no start line Bad file contents or
format - or even just a forgotten SSLCertificateKeyFile?
[Thu Jun 25 08:08:12 2009] [error] SSL Library Error: 151441516
error:0906D06C:PEM routines:PEM_read_bio:no start line Bad file contents or
format - or even just a forgotten SSLCertificateKeyFile?

Not sure why I get two errors, but two is better than none!

If I re-enable SSLCADNRequestFile, neither error appears and httpd starts
normally.

Would be great if it reported the directive & filename; ideal if also the
config filename/locn.

I'll attach a .zip file with both certificates to facilitate testing.

Thanks for your help.  I'm sure this will save other people some pain &
suffering!

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message