httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 24768] RemoveHandler without effect
Date Mon, 25 May 2009 23:59:35 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=24768


Dan Poirier <poirier@pobox.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
         Resolution|                            |WORKSFORME




--- Comment #3 from Dan Poirier <poirier@pobox.com>  2009-05-25 16:59:34 PST ---
I can't recreate this on the latest 2.0 or 2.2 Apache.

I added this to my config:

AddHandler cgi-script .html
Alias /foo "(mydocumentroot)"
<Location /foo>
  #RemoveHandler .html
</Location>

This broke access via /foo, since it tried to handle requests using cgi and
ExecCGI wasn't enabled in my docroot.

Then I uncommented the RemoveHandler, and things worked again.  It appears that
removing the handler for .html is working.

If this can be recreated some other way on (the latest) 2.0 or 2.2, this bug
report can be reopened with details.

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message