httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46949] Apache httpd serves sometimes content from another thread
Date Fri, 03 Apr 2009 11:26:21 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46949





--- Comment #4 from Sander de Boer <sander.de.boer@eo.nl>  2009-04-03 04:26:20 PST ---
I am using apache-tomcat-6.0.16 with the following connector:
  <Connector port="8009" protocol="AJP/1.3" redirectPort="443" maxThreads="512"
enableLookups="false" />

This bug is hard to reproduce. It seems that this is only a problem onder load.
Even on a test envoirement I can't reproduce it.

Because many of our clients complain to this issue, I set up a wget loop that
downloaded a test.jsp containing the word 'hello'. In this way I saw there was
sometimes other content downloaded than the word 'hello'.

I think that the errors in the error log are not related to this issue, because
the time doesnt match:
[Sun Mar 29 16:35:00 2009] [error] proxy: read zero bytes, expecting 1902 bytes
[Sun Mar 29 16:38:03 2009] [error] proxy: read zero bytes, expecting 1902 bytes
[Sun Mar 29 16:51:49 2009] [error] proxy: read zero bytes, expecting 1902 bytes

I will try a mixed version of .10 and .11, but first weekend!

-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message