httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46697] New: configure: error: ... Error, SSL/TLS libraries were missing or unusable when building apache 2.2.9
Date Wed, 11 Feb 2009 19:54:14 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46697

           Summary: configure: error: ... Error, SSL/TLS libraries were
                    missing or unusable when building apache 2.2.9
           Product: Apache httpd-2
           Version: 2.2.9
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: normal
          Priority: P1
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: skrishnamur1@bloomberg.net
                CC: rpluem@apache.org


Hi, I am trying to build apache 2.2.9 with OpenSSL 0.9.7d and am running into
the error "configure: error: ... Error, SSL/TLS libraries were missing or
unusable"
This is on solaris 9. Abstract from the configuyre log is as below

checking whether to enable mod_authz_default... shared (all)
checking whether to enable mod_auth_basic... shared (all)
checking whether to enable mod_auth_digest... checking dependencies
checking whether to enable mod_auth_digest... shared (all)
checking whether to enable mod_isapi... no
checking whether to enable mod_file_cache... no
checking whether to enable mod_cache... no
checking whether to enable mod_disk_cache... no
checking whether to enable mod_mem_cache... no
checking whether to enable mod_dbd... shared (all)
checking whether to enable mod_bucketeer... no
checking whether to enable mod_dumpio... shared (all)
checking whether to enable mod_echo... no
checking whether to enable mod_example... no
checking whether to enable mod_case_filter... no
checking whether to enable mod_case_filter_in... no
checking whether to enable mod_ext_filter... shared (all)
checking whether to enable mod_include... shared (all)
checking whether to enable mod_filter... shared (all)
checking whether to enable mod_substitute... shared (all)
checking whether to enable mod_charset_lite... no
checking whether to enable mod_deflate... checking dependencies
checking for zlib location... /usr/local
  adding "-R/usr/local/lib" to LDFLAGS
  adding "-lz" to LIBS
checking for zlib library... found
  forcing MOD_DEFLATE_LDADD to "-lz"
  removed "-lz" from LIBS

checking whether to enable mod_deflate... shared (all)
checking whether to enable mod_ldap... no
checking whether to enable mod_log_config... shared (all)
checking whether to enable mod_log_forensic... shared (all)
  adding "-I$(top_builddir)/server" to INCLUDES
checking whether to enable mod_logio... shared (all)
checking whether to enable mod_env... shared (all)
checking whether to enable mod_mime_magic... shared (all)
checking whether to enable mod_cern_meta... shared (all)
checking whether to enable mod_expires... shared (all)
checking whether to enable mod_headers... shared (all)
checking whether to enable mod_ident... shared (all)
checking whether to enable mod_usertrack... checking dependencies
checking sys/times.h usability... yes
checking sys/times.h presence... yes
checking for sys/times.h... yes
checking for times... yes
checking whether to enable mod_usertrack... shared (all)
checking whether to enable mod_unique_id... shared (all)
checking whether to enable mod_setenvif... shared (all)
checking whether to enable mod_version... shared (all)
checking whether to enable mod_proxy... no
checking whether to enable mod_proxy_connect... no
checking whether to enable mod_proxy_ftp... no
checking whether to enable mod_proxy_http... no
checking whether to enable mod_proxy_ajp... no
checking whether to enable mod_proxy_balancer... no
  adding "-I$(top_srcdir)/modules/proxy/../generators" to INCLUDES
checking whether to enable mod_ssl... checking dependencies
checking for SSL/TLS toolkit base... /opt/OpenSSL
checking for OpenSSL version... checking openssl/opensslv.h usability... yes
checking openssl/opensslv.h presence... yes
checking for openssl/opensslv.h... yes
checking openssl/ssl.h usability... yes
checking openssl/ssl.h presence... yes
checking for openssl/ssl.h... yes
OK
checking openssl/engine.h usability... yes
checking openssl/engine.h presence... yes
checking for openssl/engine.h... yes
checking for SSLeay_version in -lcrypto... no
checking for SSL_CTX_new in -lssl... no
checking for ENGINE_init... no
checking for ENGINE_load_builtin_engines... no
checking for SSL_set_cert_store... no
configure: error: ... Error, SSL/TLS libraries were missing or unusable


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message