httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46342] New: Reduce debug messages from mod_authnz_ldap
Date Thu, 04 Dec 2008 20:14:18 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46342

           Summary: Reduce debug messages from mod_authnz_ldap
           Product: Apache httpd-2
           Version: 2.3-HEAD
          Platform: All
        OS/Version: All
            Status: NEW
          Keywords: PatchAvailable
          Severity: enhancement
          Priority: P4
         Component: mod_authn_ldap
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: poirier@pobox.com


Created an attachment (id=22993)
 --> (https://issues.apache.org/bugzilla/attachment.cgi?id=22993)
Patch to reduce the number of debug messages

Using mod_authnz_ldap with loglevel debug results in 8 messages every time an
LDAP URL is parsed.  Because this happens early in startup, these go to stderr,
and on Windows create a separate error event in the event log for every
message, which is worse.  It also shows up when you do "apachectl -k stop".

I'm not sure this information needs to be logged at all (maybe left over from
when this code was developed?).  But if we do want it logged, at least we can
cut down the number of messages from 8 to 1, which will greatly reduce the
clutter in the Windows event log.

The patch provided collapses the information from the 8 separate messages into
a single message.  Instead of

[Thu Dec 04 14:14:15 2008] [debug] mod_authnz_ldap.c(918): [1160] auth_ldap url
parse: `ldap://example.com/o=apache,c=US?cn?sub?'
[Thu Dec 04 14:14:15 2008] [debug] mod_authnz_ldap.c(927): [1160] auth_ldap url
parse: Host: example.com
[Thu Dec 04 14:14:15 2008] [debug] mod_authnz_ldap.c(929): [1160] auth_ldap url
parse: Port: 389
[Thu Dec 04 14:14:15 2008] [debug] mod_authnz_ldap.c(931): [1160] auth_ldap url
parse: DN: o=apache,c=US
[Thu Dec 04 14:14:15 2008] [debug] mod_authnz_ldap.c(933): [1160] auth_ldap url
parse: attrib: cn
[Thu Dec 04 14:14:15 2008] [debug] mod_authnz_ldap.c(935): [1160] auth_ldap url
parse: scope: subtree
[Thu Dec 04 14:14:15 2008] [debug] mod_authnz_ldap.c(940): [1160] auth_ldap url
parse: filter: (null)
[Thu Dec 04 14:14:15 2008] [debug] mod_authnz_ldap.c(1016): LDAP: auth_ldap not
using SSL connections

the output is one line like this

[Thu Dec 04 14:05:06 2008] [debug] mod_authnz_ldap.c(999): [1651] auth_ldap url
parse: `ldaps://example.com:636/o=apache,c=US?cn?sub?', Host: example.com:636,
Port: 636, DN: o=apache,c=US, attrib: cn, scope: subtree, filter: (null),
connection mode: SSL


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message