httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46018] configure : Error, SSL/TLS libraries were missing or unusable
Date Thu, 06 Nov 2008 21:54:29 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46018


Ruediger Pluem <rpluem@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |NEEDINFO




--- Comment #5 from Ruediger Pluem <rpluem@apache.org>  2008-11-06 13:54:29 PST ---
(In reply to comment #3)
> I try patch acinclude.m4 and compile again.
> Result is bad :
> OK
>   forcing SSL_LIBS to "-lssl -lcrypto"
>   adding "-lssl" to LIBS
>   adding "-lcrypto" to LIBS
> checking openssl/engine.h usability... yes
> checking openssl/engine.h presence... yes
> checking for openssl/engine.h... yes
> checking for SSLeay_version... yes
> checking for SSL_CTX_new... no
> checking for ENGINE_init... yes
> checking for ENGINE_load_builtin_engines... no
> checking for SSL_set_cert_store... no
> configure: error: ... Error, SSL/TLS libraries were missing or unusable
> 
> Only set "export LIBS=-ldl" before config working OK and Apache is compiled and
> working. But it's not right solution.
> Regards,
> Libor Vejpustek
> 

Did you execute ./buildconf after applying the patch? Your output shows that
the patch is not used.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message