httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 46114] New: PUT request does not create directory
Date Wed, 29 Oct 2008 04:22:43 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=46114

           Summary: PUT request does not create directory
           Product: Apache httpd-2
           Version: 2.2.8
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: enhancement
          Priority: P2
         Component: mod_dav
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: man_and_an@yahoo.com


I have a folder called share. It has all permissions to all users.

When i say 

PUT /share/file.html HTTP/1.1
Host: localhost
Content-Length: 2

It works fine. But when i say 

PUT /share/NewFolder/file.html HTTP/1.1
Host: localhost
Content-Length: 2

Here, NewFolder is not a directory inside share. My PUT request is not creating
a new folder. How can we do that??

My error log file looks like this:

[Wed Oct 29 09:44:42 2008] [error] [client 127.0.0.1] Unable to PUT new
contents for /share/folder/filee.html.  [403, #0]
[Wed Oct 29 09:44:42 2008] [error] [client 127.0.0.1] (2)No such file or
directory: An error occurred while opening a resource.  [500, #0]


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message