httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45681] New: Segfault and Internal Server Error on loading module
Date Sun, 24 Aug 2008 09:48:07 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45681

           Summary: Segfault and Internal Server Error on loading module
           Product: Apache httpd-2
           Version: 2.2.9
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: P2
         Component: All
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: bugs@ausics.net


I build servers as follows (and with exception of disable option checking to
corect the newer automake issues) I've built apache this way for years on 
hundreds of servers:

./configure --prefix=/usr/local/apache --enable-so --enable-modules=all
--disable-dav --enable-suexec --with-suexec-docroot=/var/www
--with-suexec-caller=apache --with-suexec-logfile=/var/log/apache/suexec_log
--with-included-apr --disable-option-checking --with-mysql

This works with all server builds, until httpd.conf is given a loadmodule
statement (like adding php) then the server creates internal server error on
auth attempts, and on stopping of apache it segfaults, if I remove the php
module, it works again.

If I build it with --disable-util-dso   it all works fine (this is how I've
built all 2.2.9's since its release, I was trying to do it the newer apr way of
not building all auth modules into apache, like was previously by default in
apache builds.

I can load mod_perl without issues, I do consider this likely an apache bug
since, as mentioned, the options above have always worked and if I disable
util-dso in apache, apache behaves.

This has been replicated on 2 separate development boxes, so is not isolated
event.

The only log entry is:
[Sun Aug 24 19:18:01 2008] [notice] caught SIGTERM, shutting down
[Sun Aug 24 19:18:01 2008] [notice] seg fault or similar nasty error detected
in the parent process


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message