httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45521] New: Make mod_ssl compile with OpenSSL 0.9.9/SNAP-20080605 or later
Date Fri, 01 Aug 2008 11:22:26 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45521

           Summary: Make mod_ssl compile with OpenSSL 0.9.9/SNAP-20080605 or
                    later
           Product: Apache httpd-2
           Version: 2.3-HEAD
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_ssl
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: asfbugz@velox.ch


Created an attachment (id=22343)
 --> (https://issues.apache.org/bugzilla/attachment.cgi?id=22343)
Proposed changes for OpenSSL 0.9.9 compatibility

In early June, further type-checking enhancements to OpenSSL were committed
(http://cvs.openssl.org/chngview?cn=17247), and at the same time the
declaration of the STACK struct was removed from stack.h.

This now leads to errors such as

ssl_engine_init.c: In function 'ssl_init_ctx_verify':
ssl_engine_init.c:576: error: 'STACK' undeclared (first use in this function)
ssl_engine_init.c:576: error: (Each undeclared identifier is reported only once
ssl_engine_init.c:576: error: for each function it appears in.)
ssl_engine_init.c:576: error: expected expression before ')' token

when compiling mod_ssl against 0.9.9. The attached patch fixes these issues (as
well as some additional warnings showing up with 0.9.9).


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message