httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45371] New: MSI installer requires uninstall of previous version
Date Thu, 10 Jul 2008 10:32:26 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45371

           Summary: MSI installer requires uninstall of previous version
           Product: Apache httpd-2
           Version: 2.2.9
          Platform: PC
        OS/Version: Windows 2000
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Win32 MSI Installer
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: apache-bugzilla-ol@anova.de


The .msi installer denies to run if a previous version is installed.

It's extremely bad behaviour, it barres me from doing any elaborate
side-by-side install on productions systems.

I've used an NTFSlink ("Windows symlink") which would allow to
switch between different versions even w/o re-installing the
service nor system reboot.

And its also more or less dumb behaviour, since the only thing to
consider on a default install would have been checking whether
port 80 is in use (for that purpose, MS offers a tiny free tool
named "portqry", AFAIK) and incrementing port number and service
name, if yes.

Surely your intention was thrashing a bit at the dumb user only.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message