httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45343] New: apxs filters out ':' chars from environment variables
Date Fri, 04 Jul 2008 12:38:50 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45343

           Summary: apxs filters out ':' chars from environment variables
           Product: Apache httpd-2
           Version: 2.0.63
          Platform: Other
        OS/Version: AIX
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Build
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: francois.laupretre@ratp.fr


Happens on AIX but could happen anywhere an environment variable (CPPFLAGS,
LDFLAGS,...) contains a ':' character.

The case : On AIX, the LDFLAGS variable I use contains
'-Wl,-blibpath:/build/common'. Apache compiles OK and sets the value correctly
in config_vars.mk. But, when getting the value back from apxs ('apxs -q
LDFLAGS'), it returns '-Wl,-blibpath /build/common', replacing the first ':'
with a space.

So, when trying to link with this string (as when linking mod_jk), the linker
crashes with a message 'ld: 0706-015 The -b libpath option needs a parameter',
which is correct as the linker uses ':' as a separator, and does not understand
the space.

Tracing the problem into apxs, it comes from a substitution at the end of sub
get_vars, which says :

$result =~ s|:| |;

Commenting this line out, everything works fine for me. The problem is that, if
the code contains this substitution, there must be a reason...


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message