httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45474] Reverse proxy and very first request = Invalid direct reference to form login page.
Date Thu, 31 Jul 2008 10:51:58 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45474


Rob Stewart <rob.rstuff@googlemail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REOPENED                    |RESOLVED
         Resolution|                            |INVALID




--- Comment #3 from Rob Stewart <rob.rstuff@googlemail.com>  2008-07-31 03:51:57 PST
---
It only took two weeks - indeed this is a configuration issue.

The issue was resolved by adding 'jvmRoute' parameters to the Tomcat nodes in
the cluster and 'route' parameters to the BalanceMember elements in the Proxy
section of the Apache server.

Which is fair enough, however, the documentation...

http://tomcat.apache.org/tomcat-6.0-doc/cluster-howto.html

States quite clearly...

"If you are using mod_jk, make sure that jvmRoute attribute is set at your
Engine <Engine name="Catalina" jvmRoute="node01" >  and that the jvmRoute
attribute value matches your worker name in workers.properties"

But I'm using NOT using mod_jk or workers.properties!!

I'm moving this bug to 'invalid' but thought future bug hunters would like to
know the issue and solution.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message