httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45478] R flag in RewriteRule does not honor 400 and 500 range error code
Date Sun, 27 Jul 2008 20:18:52 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45478


Will Rowe <wrowe@apache.org> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|REOPENED                    |RESOLVED
         Resolution|                            |INVALID




--- Comment #6 from Will Rowe <wrowe@apache.org>  2008-07-27 13:18:52 PST ---
Just validated your example config;

RewriteEngine On
RewriteCond %{THE_REQUEST} "HTTP/1.[01]$"
RewriteRule .* - [R=400]

The only exception/disallowed values are those HTTPD does not issue, itself.
So for example, 499 would be invalid, but 400 or 500 for example are fine.

If you were simply testing for invalid HTTP values, are you sure you didn't
omit the ! negation symbol?  e.g. the snippet below works for me;

RewriteEngine On
RewriteCond %{THE_REQUEST} "! HTTP/1.[01]$"
RewriteRule .* - [R=400]

and no errors are reported in the error log, it accepts the R=400 value.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message