httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
Subject DO NOT REPLY [Bug 29744] CONNECT does not work over existing SSL connection
Date Fri, 11 Jul 2008 21:53:20 GMT

--- Comment #71 from Kevin Croft <>  2008-07-11 14:53:19 PST ---
Created an attachment (id=22248)
 --> (
proxy_connect patch updated for 2.2.9

Tested under Gentoo (x86_64 build) with the following steps:

Download sources & patch to /tmp
  cd /tmp
  tar jxf httpd-2.2.9.tar.bz2 
  cd httpd-2.2.9/
  cat /tmp/httpd-2.2.9-proxytunnel.patch | patch -p1

set your CFLAGS (on gentoo): 
  source /etc/make.conf

config and build:
  ./configure --enable-modules=all --enable-mods-shared=all --enable-proxy
--enable-proxy-connect --enable-proxy-ftp --enable-proxy-http --enable-ssl
  gmake all -j3

install and restart:
  find -name "*proxy*.so" | xargs cp -t /usr/lib64/apache2/modules
  apache2ctl configtest && /etc/init.d/apache2 restart

test from the remote machine:

cat ~/.ssh/config
        ProxyCommand proxytunnel -v -E -p -d %h:%p

SSL client to proxy enabled
Local proxy resolves to 123.321.111.222
Connected to (local proxy)
Tunneling to (destination)
Communication with local proxy:
 -> Proxy-Connection: Keep-Alive
 <- HTTP/1.0 200 Connection Established
 <- Proxy-agent: Apache

Tunnel established.

Configure bugmail:
------- You are receiving this mail because: -------
You are the assignee for the bug.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message