httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 45327] bindist fails to include apache_home/lib/ apr-util-1
Date Thu, 10 Jul 2008 22:18:21 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=45327





--- Comment #11 from Andy Wang <dopey@moonteeth.com>  2008-07-10 15:18:20 PST ---
Oh, I'm sorry, I didn't understand exactly where you were going so I only
pasted APU_DSO_LIBDIR=.

fgrep APU_DSO_LIBDIR config.log
APU_DSO_LIBDIR='${libdir}/apr-util-1'
#define APU_DSO_LIBDIR "/opt/ptc/apache2.2/lib/apr-util-1"

However, that doesn't work in the relocated scenario I'm referring to.  It only
works if you always install into the --prefix=blahblahblah build location.

The problem is, we are rebuilding and redistributing Apache, so the --prefix
location can't be guaranteed to always be the install location.  See this
e-mail message from Bill Rowe for a good summary of the exact problem.

http://www.mail-archive.com/dev@httpd.apache.org/msg41176.html

So we have two options:
1) fix for the bindist script and configure script to include APU_DSO_LIBDIR in
the share library path environment variable (LD_LIBRARY_PATH, LIBPATH,
SHLIB_PATH depending on platform)
2) Or the suggestion from Joe about in Comment #2 about just disabling apr-util
DSO support which makes the most sense.  Only reason I reassigned this bug to
APR was based on the e-mail thread above, it seems like maybe the apache folk
would want to visit this bug and come up with the perfect solution for all
worlds :).


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message