httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 40579] Dynamic linking of httpd on HP-UX not possible
Date Thu, 03 Jul 2008 02:06:08 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=40579





--- Comment #11 from Aaron <mingzhao.chen@hingesoftware.com>  2008-07-02 19:06:08 PST
---
(In reply to comment #10)
> HP documents their chatr tool, you'll notice the +b, +s flags work very
> similarly to the original linker.  Pay particular attention to:
>          shared library dynamic path search:
>              SHLIB_PATH     disabled  second
>              embedded path  disabled  first  Not Defined
> from the chatr information dump... you don't have SHLIB_PATH enabled.  The
> man chatr page tells you how.

Hi,Will Rowe

Yes,I did use the chatr command ,such as 'chatr +s enable httpd' etc,before I
configure the apache with the flag of '--enable-shared=no'.This way can make
SHLIB_PATH enabled.You can see the Comment #5 by me.The SHLIB_PATH have been
enabled.But there are still flag of 'static' to the .sl and the apache can not
work on the other machine.

By the way,as to the problem occured on the AIX,could you tell mey what's
happend?Tanks a lot.

Aaron,
2008-07-03


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message