httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 40579] Dynamic linking of httpd on HP-UX not possible
Date Thu, 26 Jun 2008 03:49:51 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=40579


Aaron <mingzhao.chen@hingesoftware.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |mingzhao.chen@hingesoftware.
                   |                            |com
             Status|NEEDINFO                    |ASSIGNED




--- Comment #5 from Aaron <mingzhao.chen@hingesoftware.com>  2008-06-25 20:49:50 PST
---
I'm try to build the Apache2.0.59 on HP-UX with this configuration:
./configure --prefix=/export/home/apache2 --enable-ssl
--with-ssl=/usr/local/openssl --with-expat=builtin 
./make
./make install

Then I execute the ./apachectl start in the /export/home/apache2/bin,it can run
normally.But when I move the apache to another directory(/opt/oracle/apache2)
and I remove the /export/home/apache2,and I edit the
PREFIX(/export/home/apache2) to new directory in the following
files:apachectl,apxs,envvars,httpd.conf,ssl.conf.When I run the apache ,I get
following error:

/usr/lib/dld.sl: Can't open shared library:
/export/home/apache2/bin/libapr.sl.0
/usr/lib/dld.sl: No such file or directory

And I copy the apache to another HP-UX and also edit the above PREFIX info,I
get the same error.

I echo the 'SHLIB_PATH' and it just the new lib path:/opt/oracle/apache2/lib;

In the PREFIX/bin,#chatr httpd,the httpd's info is :

httpd:
         shared executable
         shared library dynamic path search:
             SHLIB_PATH     enabled   second
             embedded path  disabled  first  /export/home/apache2/lib
         shared library list:
             static    /export/home/apache2/lib/libaprutil.sl.0
             static    /export/home/apache2/lib/libexpat.sl.1
             static    /export/home/apache2/lib/libapr.sl.0
             dynamic   /usr/lib/libm.2
             dynamic   /usr/lib/libnsl.1
             dynamic   /usr/lib/libpthread.1
             dynamic   /usr/lib/libc.2
         shared library binding:
             deferred
         global hash table disabled
         plabel caching disabled
         global hash array size:1103
         global hash array nbuckets:3
         shared vtable support disabled
         static branch prediction disabled
         executable from stack: D (default)
         kernel assisted branch prediction enabled
         lazy swap allocation disabled
         text segment locking disabled
         data segment locking disabled
         third quadrant private data space disabled
         fourth quadrant private data space disabled
         third quadrant global data space disabled
         data page size: D (default)
         instruction page size: D (default)
         nulptr references disabled
         shared library private mapping disabled
         shared library text merging disabled



Didn't you know what's the matter? Other UNIX systems, just like SunOS work
fine.Could you please help me?Thanks very much!


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message