httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 44592] mod_proxy fails to send post request to backend server
Date Tue, 24 Jun 2008 19:51:51 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=44592





--- Comment #15 from Ruediger Pluem <rpluem@apache.org>  2008-06-24 12:51:50 PST ---
(In reply to comment #14)

> 
> Attachment error2-client-213244.pcap is network between client and server
> (filtered only the client affected) frame 257 is the request and 271 the
> response.

Thanks for the dump. I evaluated the request send by the client and the client
fails to send the request body:

00000786  63 4d 37 5a 49 33 59 25  33 64 0d 0a 0d 0a       cM7ZI3Y% 3d....

The string cM7ZI3Y%3d is the end of the value for the MYSAPSSO2 cookie.
Afterwards the client sends \r\n\r\n which tells the server that the headers
are now finished an that the request body follows next. But the client does not
send a request body!
It seems that this request is sent via AJAX:

x-requested-with: XMLHttpRequest

Are you sure that there is no bug in your AJAX javascript? Using POST is not
the typical way of using XMLHttpRequest. It requires some things to be done.
Maybe something got wrong there in the javascript on the client side.

So in short: For this request httpd just works as designed besides that it
should sent a 400 instead of a 500 return code. But I think this is fixed since
2.2.9.


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message