httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 44907] New: SSL 400 Bad Request with no status and headers
Date Wed, 30 Apr 2008 08:32:36 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=44907

           Summary: SSL 400 Bad Request with no status and headers
           Product: Apache httpd-2
           Version: 2.2.8
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_ssl
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: christian.liesch@united-security-providers.ch


If I do send plain HTTP to an SSL enabled vhost the expected 400 Bad Request
Answer do not have any HTTP headers nor a status line only the HTML is sent.

Request:
GET /foobar HTTP/1.1 
Host: localhost  

Response:
<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN"
<html><head
<title>400 Bad Request</title
</head><body
<h1>Bad Request</h1
<p>Your browser sent a request that this server could not understand.<br /
Reason: You're speaking plain HTTP to an SSL-enabled server port.<br /
Instead use the HTTPS scheme to access this URL, please.<br /
<blockquote>Hint: <a
href="https://xxx:yyy/"><b>https://xxx:yyy/</b></a></blockquote></p
</body></html OK


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message