httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 44614] New: ServerAlias/ServerName broken?
Date Mon, 17 Mar 2008 06:31:01 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=44614

           Summary: ServerAlias/ServerName broken?
           Product: Apache httpd-2
           Version: 2.2.8
          Platform: PC
               URL: http://www.world.net
        OS/Version: Windows XP
            Status: NEW
          Severity: normal
          Priority: P2
         Component: All
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: sherman.chan@world.net


Hi,
I'm not sure who I should talk to PHP or Apache, after I upgrade apache-2.2.8
from apache 1.3.37, I found both php variable $SERVER_NAME and $HTTP_HOST were
return the same value, unlike I found on apache 1.3.37.

my web host setup as follow
<VirtualHost xxxx :80>
DocumentRoot /path/to/WebRoot
ServerName    aaa.bbb.ccc
ServerAlias   xxx.yyy.zzz
</VirtualHost>

on apache 1.3.37
if I browse xxx.yyy.zzz, I have the following values on those 2 the php
variables
$SERVER_NAME = aaa.bbb.ccc
$HTTP_HOST = xxx.yyy.zzz

however on apache 2.2.8, I got 
$SERVER_NAME = xxx.yyy.zzz, i was expect aaa.bbb.ccc to be return
$HTTP_HOST = xxx.yyy.zzz


Could you let me know what should I go to get apache 2.2.8 behavior same as
apache 1.3.x or should I forward this issue to php.

Thanks
Sherman


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message