httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 44639] Segmentation fault 11 errors right after server started up
Date Thu, 20 Mar 2008 18:06:41 GMT
https://issues.apache.org/bugzilla/show_bug.cgi?id=44639


Dave <davelee53@yahoo.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEEDINFO                    |ASSIGNED




--- Comment #7 from Dave <davelee53@yahoo.com>  2008-03-20 11:06:40 PST ---
(In reply to comment #4)
> (In reply to comment #2)
> > Here you go. Thanks, dave
> > 
> > 
> >   main(0x3, 0xffbff07c, 0xffbff08c, 0x3a6c00, 0x0, 0x0)
> >    ap_mpm_run(0x3ddaf0, 0x41fbf8, 0x3e4298, 0x3e4298, 0x0, 0x0)
> >    perform_idle_server_maintenance(0x3ddaf0, 0xffbfef44, 0xffbfef30, 0x3ddaf0, 
> >          0x3e4298, 0x377990)
> >    make_child(0x3e4298, 0x0, 0xffbfef48, 0x1, 0x3ddaf0, 0x348864)
> >    child_main(0x0, 0x2367b8, 0x1, 0x0, 0xffbfee50, 0xffbfee40)
> >    unixd_setup_child(0x0, 0x520440, 0x567090, 0x0, 0x0, 0x0)
> >    set_group_privs(0x0, 0x567090, 0x520440, 0x0, 0x0, 0x0)
> >    _initgroups(0x4efbb0, 0x65, 0x0, 0x0, 0x0, 0x0)
> >    _getgroupsbymember(0x4efbb0, 0x560658, 0x10, 0x1, 0x0, 0x5606a1)
> >    _nss_search(0x2, 0xfeeb614c, 0x56b090, 0xffbfeb44, 0x4e455449, 0xff03f084)
> >    0xfeeb6178(0x55fee8, 0xffbfeb44, 0x30, 0x56b0e8, 0x72000000, 0x72000000)
> >    0xfeeb2e50(0x2, 0xff000000, 0x0, 0x56b144, 0x0, 0x0)
> >    0xfee89d90(0x0, 0x0, 0x0, 0xfeebbea8, 0xfeebbeb8, 0xfeece478)
> >    0xfee89768(0x4debd8, 0x566b98, 0x4dd5f8, 0x0, 0x0, 0xffbfe520)
> >    0xfee888ac(0xffffffff, 0x566b98, 0x1, 0xffbfe524, 0x0, 0x40)
> >    0xfee88170(0x0, 0x3, 0xfeea1f78, 0xfeea2304, 0xad8, 0x1)
> >    0x0(0x0, 0x800, 0x0, 0x0, 0x800, 0x0)
> > 
> 
> Could you please provide a gdb backtrace? It should give us more information.
> 

This issue occurred on a Customer production box that does not have debug tool
like gdb.
Also, the Apache we built is using Sun's cc compiler, not the g++. Doesn't gdb
only debug symbols that are generated by g++? The stack traces I provided above
was from a core dump using Sun's workshop (dbx). I can email you the core file
if you need.
thanks,
dave


-- 
Configure bugmail: https://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message