httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 44272] New: - Wrong error message for missing directory
Date Mon, 21 Jan 2008 06:43:49 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=44272>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=44272

           Summary: Wrong error message for missing directory
           Product: Apache httpd-2
           Version: 2.2.6
          Platform: Other
               URL: http://www.apache.org/index/
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Core
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: worldhello.net@gmail.com


When visit http://www.apache.org/index/ , reture a 404 not found page.
But instead of saying /index/ not found, it says "/index.html/" not found!
Isn't is strange?  It maybe nothing hurt, but in some cases it is really bad.

For example, there is a location in httpd config file:
    <location something/>
        handler...
    </location>
we can access http://domain.name/something/.., without create directory
something in wwwroot.
But if there is a file "wwwroot/something.ext" already exist, we have to create
direcotry "wwwroot/something" before access it.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message