httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 19188] - ProxyPass'ing to HTTPS server via proxy does not work
Date Tue, 15 Jan 2008 01:05:29 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=19188>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=19188





------- Additional Comments From pgollucci@apache.org  2008-01-14 17:05 -------
I believe I've hit this too:

In production, I have a hardware load balancer, but in stage, I'm trying to
simulate it using httpd and mod_proxy_balancer.

I think I might be getting this error regardless of SSL in use or not.

LB--->PXY and PXY SSL Layer--->App Layer

LB is httpd+mod_proxy_balancer

The proxy layer is identical, except there are some application level rewrite
rules in place for SSL, maintenance, denials, etc...

Listen *:80
<VirtualHost *>
  ...
  ProxyPass / balancer://pxy_cluster/
  ProxyPassReverse / balancer://pxy_cluster/
  ProxyPreserveHost on

  ### mod_proxy balancer
  <Proxy balancer://pxy_cluster>
    BalancerMember http://pxy001.tld
    BalancerMember http://pxy002.tld
  </Proxy>
</VirtualHost>

----
Listen *:443
<VirtualHost *>
    ...

    ### SSL
    SSLEngine  On
    SSLProxyEngine on

    ### mod_proxy balancer
    <Proxy balancer://pxy_cluster>
      BalancerMember https://pxy001.tld
      BalancerMember https://pxy002.tld
    </Proxy>
</VirtualHost>

--------
==> error_log <==
[Tue Jan 15 01:01:47 2008] [debug] mod_proxy_balancer.c(41): proxy: BALANCER:
canonicalising URL //pxy_cluster/
[Tue Jan 15 01:01:47 2008] [debug] mod_proxy_balancer.c(950): proxy: Entering
byrequests for BALANCER (balancer://pxy_cluster)
[Tue Jan 15 01:01:47 2008] [debug] mod_proxy_balancer.c(517): proxy: BALANCER
(balancer://pxy_cluster) worker (http://pxy001.tld) rewritten to http://pxy001.tld/
[Tue Jan 15 01:01:47 2008] [debug] mod_proxy.c(819): Running scheme balancer
handler (attempt 0)
[Tue Jan 15 01:01:47 2008] [debug] mod_proxy_http.c(1693): proxy: HTTP: serving
URL http://pxy001.tld/
[Tue Jan 15 01:01:47 2008] [debug] proxy_util.c(1852): proxy: HTTP: has acquired
connection for (pxy001.tld)
[Tue Jan 15 01:01:47 2008] [debug] proxy_util.c(1913): proxy: connecting
http://pxy001.tld/ to pxy001.tld:80
[Tue Jan 15 01:01:47 2008] [debug] proxy_util.c(2012): proxy: connected / to
pxy001.tld:80
[Tue Jan 15 01:01:47 2008] [debug] proxy_util.c(2109): proxy: HTTP: backend
socket is disconnected.
[Tue Jan 15 01:01:47 2008] [debug] proxy_util.c(2169): proxy: HTTP: fam 2 socket
created to connect to pxy001.tld
[Tue Jan 15 01:01:47 2008] [debug] proxy_util.c(2266): proxy: HTTP: connection
complete to 192.168.1.165:80 (pxy001.tld)
[Tue Jan 15 01:01:48 2008] [debug] mod_proxy_http.c(1478): proxy: start body send
[Tue Jan 15 01:01:48 2008] [debug] mod_proxy_http.c(1567): proxy: end body send
[Tue Jan 15 01:01:48 2008] [debug] proxy_util.c(1870): proxy: HTTP: has released
connection for (pxy001.tld)

------
Down stream PXY's access_log (LB-->PXY)
==> access_log <==
192.168.1.49 XXXXXXXXXXXXXXXXXXXX [15/Jan/2008:01:03:06 +0000] "GET / HTTP/1.1"
200 108 "-" "Mozilla/5.0 (X11; U; FreeBSD i386; en-US; rv:1.8.1.6)
Gecko/20070819 Firefox/2.0.0.6

error_log from same server had nothing written to it.


-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message