httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43534] - mod_perl and FastCGI fails on Windows
Date Sun, 06 Jan 2008 17:38:45 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=43534>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=43534


wrowe@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|ASSIGNED                    |NEEDINFO




------- Additional Comments From wrowe@apache.org  2008-01-06 09:38 -------
Here we go;

on Unix, apr_proc_detach(1) causes all of the descriptors to be replaced with
the /dev/null handle, and this is precisely the behavior we want.

Today on unix this occurs in pre_config (c.f. worker.c and prefork.c).  However
this behavior is a bit borked in the minds of some developers, who are frustrated
with the fact that perl emits that showed up in 1.3 no longer show up in 2.0.
But I can agree for now that we have to mirror unix, at least our register_hooks
and earlier pre_config hooks will mirror unix.

See the revised patch which only modifies normal console-mode operation at;

  http://svn.apache.org/viewvc?view=rev&revision=609354

review and let me know if this satisfies your test cases, and I'll backport
ASAP.



-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message