httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 44152] - litmus regression: PUT conditional on lock and etag failed
Date Sat, 29 Dec 2007 13:51:46 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=44152>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=44152





------- Additional Comments From michael@metaparadigm.com  2007-12-29 05:51 -------
The date issue and Etag I mentioned is a red herring.

Here the test is succedding on 2.2.7-dev with the 64bit etag patches reversed
(Dates are equal and ETag is weak - so not related).

Must be one of the 64 bits casts is putting garbage in the Etag making the
condition fail.

This is a successful run on 32bit Linux with the patch reversed.


******* Running test 15: cond_put ********
ah_create, for WWW-Authenticate
Running pre_send hooks
auth: Sending 'Basic' response.
Sending request headers:
HEAD /uploads/litmus/lockme HTTP/1.1
Host: localhost
User-Agent: litmus/0.11 neon/0.26.3
Connection: TE
TE: trailers
Authorization: Basic bWNsYXJrOnNhZ2kxNzcx
X-Litmus: locks: 15 (cond_put)

Sending request-line and headers:
Request sent; retry is 1.
[status-line] < HTTP/1.1 200 OK
[hdr] Date: Sat, 29 Dec 2007 13:46:43 GMT
Header Name: [date], Value: [Sat, 29 Dec 2007 13:46:43 GMT]
[hdr] Server: Apache/2.2.7-dev (Unix) DAV/2
Header Name: [server], Value: [Apache/2.2.7-dev (Unix) DAV/2]
[hdr] Last-Modified: Sat, 29 Dec 2007 13:46:43 GMT
Header Name: [last-modified], Value: [Sat, 29 Dec 2007 13:46:43 GMT]
[hdr] ETag: W/"ec400e-20-a9136c0"
Header Name: [etag], Value: [W/"ec400e-20-a9136c0"]
[hdr] Accept-Ranges: bytes
Header Name: [accept-ranges], Value: [bytes]
[hdr] Content-Length: 32
Header Name: [content-length], Value: [32]
[hdr] Content-Type: text/plain
Header Name: [content-type], Value: [text/plain]
[hdr] 
End of headers.
Running post_send hooks
ah_post_send (#0), code is 200 (want 401), WWW-Authenticate is (none)
Request ends, status 200 class 2xx, error line:
200 OK
Running destroy hooks.
Request ends.
ah_create, for WWW-Authenticate
Running pre_send hooks
auth: Sending 'Basic' response.
Sending request headers:
PUT /uploads/litmus/lockme HTTP/1.1
Host: localhost
User-Agent: litmus/0.11 neon/0.26.3
Connection: TE
TE: trailers
Content-Length: 32
If: (<opaquelocktoken:7da06b5a-b614-11dc-89f6-f543e31a2f21> [W/"ec400e-20-a9136c0"])
Authorization: Basic bWNsYXJrOnNhZ2kxNzcx
X-Litmus: locks: 15 (cond_put)

Sending request-line and headers:
Sending request body:
Body block (32 bytes):
[This
is
a
test
file
called
foo

]
Request sent; retry is 1.
[status-line] < HTTP/1.1 204 No Content
[hdr] Date: Sat, 29 Dec 2007 13:46:43 GMT
Header Name: [date], Value: [Sat, 29 Dec 2007 13:46:43 GMT]
[hdr] Server: Apache/2.2.7-dev (Unix) DAV/2
Header Name: [server], Value: [Apache/2.2.7-dev (Unix) DAV/2]
[hdr] Content-Length: 0
Header Name: [content-length], Value: [0]
[hdr] Content-Type: text/plain
Header Name: [content-type], Value: [text/plain]
[hdr] 
End of headers.
Running post_send hooks
ah_post_send (#0), code is 204 (want 401), WWW-Authenticate is (none)
Request ends, status 204 class 2xx, error line:
204 No Content
Running destroy hooks.
Request ends.


-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message