httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43900] New: - proxy response contains unspecified characters
Date Mon, 19 Nov 2007 11:54:13 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=43900>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=43900

           Summary: proxy response contains unspecified characters
           Product: Apache httpd-2
           Version: 2.2.4
          Platform: Sun
        OS/Version: Solaris
            Status: NEW
          Keywords: RFC
          Severity: blocker
          Priority: P2
         Component: mod_proxy
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: ajay.pant@xansa.com
                CC: ajay.pant@xansa.com


Sometime on repeated requests there are extra character added to response, when 
data is fetched in blocks. I have mu Application server requesting data from 
third party using Apache proxy (ver 2.2.4). To check I switched on the dumpio 
modules and see that sometime the data-TRANSIENT data is written to the 
response buffer, in addition to data-Heap. This caused the response XML parser 
to fail. Though this happens occasionally. Here is part of dumpio output :

        <param 
name="store_number">0292</param>\n                                <param 
name="GeocodeDate">2007-10-30</param>\n                                <param

name="GeocodeSource">cp073</param>\n                                <param 
name="client_id"></param>\n                                <param 
name="street"></param>\n                                <param 
name="town"></param>\n                
[Tue Nov 13 14:49:33 2007] [debug] mod_dumpio.c(139): mod_dumpio: dumpio_out
[Tue Nov 13 14:49:33 2007] [debug] mod_dumpio.c(55): mod_dumpio:  dumpio_out 
(data-TRANSIENT): 5 bytes
[Tue Nov 13 14:49:33 2007] [debug] mod_dumpio.c(71): mod_dumpio:  dumpio_out 
(data-TRANSIENT): 71c\r\n
[Tue Nov 13 14:49:33 2007] [debug] mod_dumpio.c(55): mod_dumpio:  dumpio_out 
(data-HEAP): 1820 bytes
[Tue Nov 13 14:49:33 2007] [debug] mod_dumpio.c(71): mod_dumpio:  dumpio_out 
(data-HEAP):    <param 
name="ph_open_sat"></param>\n                                <param 
name="ph_close_sat"></param>\n                                <param 
name="ph_open_sun"></param>\n         

and here is the part of resulted XML file returned by Apache to Application 
server:
                                <param name="ph_close_thu"></param>
                                <param name="ph_open_fri"></param>
                                <param name="ph_close_fri"></param>
           ^M
71c^M
                     <param name="ph_open_sat"></param>
                                <param name="ph_close_sat"></param>
                                <param name="ph_open_sun"></param>
.
.

I have tried to compile Apached 2.0.61 also, but getting the same problem there 
also. I am using  Sun zone Architecture m/c with Solaris 10.  With Application 
server running on Zone 1( Weblogic 9) and proxy Apache 2.2.2 running on Zone 2.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message