httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43802] New: - Failed to comply to new DocumentRoot (and possibly on other directives)
Date Wed, 07 Nov 2007 00:09:40 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=43802>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=43802

           Summary: Failed to comply to new DocumentRoot (and possibly on
                    other directives)
           Product: Apache httpd-2
           Version: 2.2.6
          Platform: PC
               URL: http://www.apachelounge.com/forum/viewtopic.php?p=9057
        OS/Version: Windows Vista
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Core
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: enerata@gmail.com


Hello,
This is the description of the problem (a user gave it on the URL accompaning URL):

"I've just installed apache v2.2.6 and am trying to change the DocumentRoot to a
separate drive, D drive, which it doesn't seem to like.

For example, if I set the DocumentRoot to:

DocumentRoot "C:/test"
...
<Directory "C:/test">

Then everything works fine, however if I move the directory and change those to
D:/test, then try to restart the service, it gives me an error saying "The
requested operation has failed", and that's it.
I've also tried setting up virtual hosts but I get the same result, it works
fine on C drive but as soon as I try on D drive the apache service won't even start.

I've been searching but have been unable to find any help. I've found a couple
of posts with people asking about the same problem but none have had answers.
One such post here: http://www.webservertalk.com/archive199-2004-2-116658.html

Though strangely he says it worked when he tried it on Windows XP, which is what
I am running it on.

I could just copy my local copy to C drive, but I would really rather not do
that if I don't need to, so if anyone could help that would be greatly
appreciated. If I've left out any important information, which I probably have,
let me know and I'll post it."

I personally cannot even change the DocumentRoot to a location into my C. Maybe
it's a bug of "httpd.exe -k start", because issueing "httpd.exe -w -e debug" for
example, makes apache to comply to new configuration (DocumentRoot).

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message