httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43577] - I'm concerned about apache portability about mod_authnz_ldap
Date Tue, 09 Oct 2007 15:18:39 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=43577>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=43577





------- Additional Comments From alcol@hotmail.com  2007-10-09 08:18 -------
Thank about leaving it (for now) as needing info and not as invalid! mainly 
becouse undel RedHat Linux it work

Linux xxxxxxxxxxxxxx 2.4.20-8smp #1 SMP Thu Mar 13 17:45:54 EST 2003 i686 i686 
i386 GNU/Linux

Win32 is a Windows 2000 platorm English language with Sp4 all all installed 
from MS Windows Update WEB site.

The only differenceis that the MSI package from APACHE download (for WINDOWS) 
is compiled with MS LDAP SDK. On Linux I use Novell SDK but work fine with 
Netscape IPLANET sdk too.

Why the same httpd.conf don't work if is working under linux?


I have added these lines inside the httpd.conf for Windows:

LoadModule ldap_module modules/mod_ldap.so
LoadModule authnz_ldap_module modules/mod_authnz_ldap.so

below....

Alias /swd "d:/Inetpub/ftproot/directory"
<Location /directory>
  Order deny,allow
  Allow from 10.0.0.0/8
  Deny from all
  ReadmeName README
  HeaderName HEADER
  AuthType basic
  AuthBasicProvider ldap
  AuthName "REALM REALM"
  AuthLDAPUrl ldap://ldap.domain.top:389/O=xxx,c=yy?uid?sub NONE
  AuthLDAPBindDN ldapuser
  AuthLDAPBindPassword ldappassword
  AuthzLDAPAuthoritative off
  AuthLDAPRemoteUserIsDN on
  require valid-user
  Options MultiViews Indexes SymLinksIfOwnerMatch IncludesNoExec
</Location>

error.log (LogLevel DEBUG):
[Tue Oct 09 15:01:43 2007] [debug] mod_authnz_ldap.c(376): [client 10.x.x.x] 
[1572] auth_ldap authenticate: using URL ldap://ldap.domain.top:389/O=xxx,c=yy?
uid?sub
[Tue Oct 09 15:01:43 2007] [warn] [client 10.x.x.x] [1572] auth_ldap 
authenticate: user  authentication failed; URI /swd/ [ldap_search_ext_s() for 
user failed][Errore di filtro]



-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message