httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43482] New: - AuthLDAPURL must contain a final path of branch?(ldap_search_ext_s)
Date Wed, 26 Sep 2007 12:11:35 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=43482>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=43482

           Summary: AuthLDAPURL must contain a final path of
                    branch?(ldap_search_ext_s)
           Product: Apache httpd-2
           Version: 2.2.3
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Keywords: ErrorMessage
          Severity: critical
          Priority: P2
         Component: mod_authn_ldap
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: ayed.akrout@gmail.com
                CC: ayed.akrout@gmail.com


the configuration with the module authnz_ldap worked very well.
with this line:(apache look for authentification in full AD
"ldap://10.x.y.z:389/DC=Domain?sAMAccountName?sub?(objectClass=user
 since yesterday a fatal error appeared: Internal Server Error
when I look at apache2'log file I find:



*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
*** glibc detected *** corrupted double-linked list: 0x083b91f0 ***
[warn] [client 127.0.0.1][7709] auth_ldap authentificate: user salah
authentificate failed; URI /SimpleRepos [ldap_search_ext_s() for user
failed][Operation error]




I try to change configuration and make it more precised:
AuthLDAPURL
"ldap://10.x.y.z:389/OU=Users,OU=XYZ,DC=Domain?sAMAccountName?sub?(objectClass=user
)"

Now it work but only for users in "OU=Users,OU=XYZ,DC=Domain"

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message