httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43328] - mod_authnz_ldap does not compile
Date Tue, 11 Sep 2007 14:37:28 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=43328>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=43328





------- Additional Comments From r.sokoll@intershop.de  2007-09-11 07:37 -------
(In reply to comment #10)

> Try using --with-ldap-include, --with-ldap-lib, --with-ldap rather than 
> setting the CFLAGS and LDFLAGS

That worked, thank you.
What confused me:
In the top level directory, I did a "./configure --help" to see what options are
needed/supported.
There are only 2 ldap related options:
  --enable-authnz-ldap    LDAP based authentication
  --enable-ldap           LDAP caching and connection pooling services

That is why I set CFLAGS and LDAP to tell the compiler/linker where to find the
headers/libs.

You are correct: There is no bug in the source - but someone should really
update the main configure script.
BTW: "srclib/apr-util/configure --help" prints the options you mentioned.

This could confuse other users too, I think.
Anyway: Thank you for your time. If you wish, you may close this ticket (or
better: reassign it to the person who is responsible for configure)

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message