httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 43334] - Garbage characters in Server header and version string when using mod_ssl statically
Date Sun, 09 Sep 2007 19:11:15 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=43334>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=43334


rpluem@apache.org changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |NEEDINFO




------- Additional Comments From rpluem@apache.org  2007-09-09 12:11 -------
Could you please try if the following makes the error go away?:

Index: ssl_engine_vars.c
===================================================================
--- ssl_engine_vars.c   (Revision 573732)
+++ ssl_engine_vars.c   (Arbeitskopie)
@@ -640,7 +640,7 @@
     static char *library = NULL;
     char *result;

-    if (!library) {
+    {
         char *cp, *cp2;
         library = apr_pstrdup(p, SSL_LIBRARY_DYNTEXT);
         if ((cp = strchr(library, ' ')) != NULL) {

This patch is no solution, but should help finding the root cause. I for myself
cannot reproduce this currently.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message