httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 42125] New: - Cannot load php4 module in Apache 2.2.4
Date Sat, 14 Apr 2007 08:44:20 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=42125>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=42125

           Summary: Cannot load php4 module in Apache 2.2.4
           Product: Apache httpd-2
           Version: 2.2.4
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Runtime Config
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: david@ols.es


Actual result:
--------------
httpd: Syntax error on line 9 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/modules/libphp4.so into server:
/usr/local/apache/modules/libphp4.so: undefined symbol:
ap_hook_pre_config

Expected result:
----------------
apache succesfully loads php module

Reproduce code:
---------------
 ./configure --prefix=/usr/local/apache2 \
        --disable-include --disable-actions --disable-asis \
        --disable-cgi --enable-deflate --enable-expires \
        --enable-headers --enable-info --enable-rewrite \
        --enable-so --enable-ssl --enable-usertrack \
        --with-mpm=prefork --with-included-apr

./configure --with-mysql \
        --with-apxs2=/usr/local/apache/bin/apxs \
        --enable-track-vars --enable-versioning \
        --enable-sockets --enable-dbase \
        --enable-exif --with-mm --with-iconv \
        --with-png-dir --enable-ftp \
        --with-xml --with-dbase --with-ftp --with-gdbm \
        --with-imap-ssl=$(IMAP) -with-gd \
        --with-zlib=/usr --with-mime-magic \
        --with-curl=/usr/local --with-openssl \
        --with-pcre --with-mcrypt --disable-cgi \
        --enable-gd-native-ttf --enable-mbstring \
        --enable-inline-optimization \
        --disable-debug --disable-display-source \
        --enable-memory-limit --with-jpeg-dir --with-tiff-dir \
        --without-pear --with-dom

this is very similar to those 'bugs':

http://bugs.php.net/bug.php?id=24199

i know this is has not been cosidered as a real bug, but i did not
found anything helpful in any php or apache support site (even using
google)

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message