httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41041] - mod_ldap segfaults when using TLS w/OpenLDAP libs
Date Fri, 30 Mar 2007 00:38:44 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41041>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41041





------- Additional Comments From e61559@ems.rmit.edu.au  2007-03-29 17:38 -------
(In reply to comment #4)

Apache/APR should *see* the OpenLDAP libraries, but the Sun linker (/usr/ccs/ld) 
needs the -R flag to hardcode the runtime library path. You can also get around
this with setting LD_LIBRARY_PATH, but I'm not a fan of relying on environment
settings this sort of thing.

(we also have the rather nasty case where apr-0.9.2 is in /usr/local and
apr-1.2.x is in /usr/local/pkg/apr1, so we have to dodge that as well)

It was rather entertaining actually: building against OpenLDAP but linking to
Sun LDAP *did* work for non-encrypted LDAP, but blew up spectacularly in the
other cases.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message