httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41142] - Endless loop in apr_allocator_destroy
Date Tue, 13 Mar 2007 12:21:02 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41142>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41142





------- Additional Comments From hpw@hp-weidinger.at  2007-03-13 05:21 -------
I had a simmilar Problem with apr when destroying a pool twice.
(Call apr_pool_destroy twice on the same pool).

This causes the allocators "free" list to be corrupted.

Next time, you call 
apr_pool_create(newpool,NULL)
apr_pool_create(newpool2,newpool) you get 2 identical nodes, where
parent and child seem to be self-references.

in allocator_destroy (called by apr_terminate) this leads to an endless loop.

Maybe it would help to enhance the apr-functions with debug output.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message