httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 39243] - Can't post files larger than 128k onto ssl client cert secured site
Date Sun, 04 Mar 2007 00:50:52 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=39243>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=39243





------- Additional Comments From asfbugzilla@gnosys.biz  2007-03-03 16:50 -------
Sorry.  I should have added above that there are no client certificates involved
in these uploads.  I'm not savvy enough about the internals of either apache or
plone to know, but I suppose that means it's possible that what I'm seeing is
not actually this bug, but the behavior of my systems match the symptoms in
every way except for the involvement of client certificates, so to me that means
that if they are not the same, then they are at least, very probably strongly
associated with each other.

When I upload files 128kb and smaller, it works as expected.  When I attempt to
upload files 129kb and larger, I get this:

Error message in browser:
Title: 413 Request Entity Too Large
Page: Request Entity Too Large
The requested resource
/Members/admin/portal_factory/Image/image.2007-03-03.9545920618/atct_edit
does not allow request data with POST requests, or the amount of data provided
in the request exceeds the capacity limit.

Error message in logs:
[Sat Mar 03 19:26:35 2007] [error] [client xxx.yyy.zzz.ttt] request body exceeds
maximum size for SSL buffer, referer:
https://www.example.com/Members/admin/portal_factory/Image/image.2007-03-03.9545920618/edit
[Sat Mar 03 19:26:35 2007] [error] [client xxx.yyy.zzz.ttt] could not buffer
message body to allow SSL renegotiation to proceed, referer:
https://www.example.com/Members/admin/portal_factory/Image/image.2007-03-03.9545920618/edit

I've spoken with someone on the plone list who's using RHEL and apache/ssl/plone
in the same manner that I am, and he reports not suffering from this problem. 
I'm not sure if he has any upper limit at all, or if the upper limit is simply
larger than 128kb.  I'm still talking with him.

I guess redhat has applied some sort of patch.  Does anyone know about that?  Is
it the same one mentioned in this bug report?  I'd like to have the limit (if it
must exist) be up in the 40-50 MB range myself.  If there's another patch,
perhaps someone could refer me to it?

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message