httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29744] - CONNECT does not work over existing SSL connection
Date Wed, 21 Feb 2007 11:13:04 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29744>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29744





------- Additional Comments From lionel.victor@free.fr  2007-02-21 03:13 -------
Well.. I have not tested the latest patch. I did not post mine because it is 
more a hack than a patch...

You can get my source file here:

http : lionel.victor.free.fr/mod_proxy_connect.c

I did not produce a diff so you can diff it yourself from your source and 
verify what I did. (be carefull, i changed indentation so you'd better use -w 
when using diff)

the source above is modified from the original 2.2.3 source code downloaded 
from the apache project.

Now, concerning your problem, I advise you to really debug step by step. I 
first though that i would use proxytunnel alone (with the encrypt option) but 
I was wrong... I definitely had a problem similar to yours.
However, I am using mutual authentication on some parts of my HTTPS host, I 
therefore though that proxytunnel could not handle the special SSL handshake. 
Maybe it just does not work at all with SSL...

I'm now using proxytunnel to link to my machine (and listen to local 
connections), then stunnel to open the ssl tunnel and present the client 
certificate... then another proxytunnel to do what I have to do.

hope it helps

(In reply to comment #33)
> I tried the latest patch given (by Mark, the one against the 2.2.2 version), 
and
> applied it to the 2.2.3 tree.  It did not work, in the sense that proxytunnel
> said the following:
> burnside:~ $ ssh -p 8080 localhost
> SSL enabled
> localhost is 127.0.0.1
> Connected to localhost:443
> Tunneling to localhost:8080 (destination)
> Connect string sent to Proxy: 'CONNECT localhost:8080 HTTP/1.0
> Proxy-Connection: Keep-Alive
> '
> DEBUG: recv: ''analyze_HTTP: borken
> Unsupported HTTP version number
> ssh_exchange_identification: Connection closed by remote host
> So it seems that the problem may still be there.  Any suggestions?
>    Julian



-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message