httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41459] New: - Extensive number of "HTTP spoken on HTTPS port" info messages for IPv6
Date Thu, 25 Jan 2007 09:17:46 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41459>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41459

           Summary: Extensive number of "HTTP spoken on HTTPS port" info
                    messages for IPv6
           Product: Apache httpd-2
           Version: 2.2.4
          Platform: Other
        OS/Version: AIX
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_ssl
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: Bjorn.Wiberg@its.uu.se


After having migrated from Apache 2.0.x to Apache 2.2.3 (and 2.2.4), I get a lot
of these error messages in the error log:

---8<---
[Mon Jan 22 01:02:13 2007] [info] [client 2001:6b0:b:2::27] Connection to child
12 established (server www.anst.uu.se:443)
[Mon Jan 22 01:02:13 2007] [info] Seeding PRNG with 136 bytes of entropy
[Mon Jan 22 01:02:13 2007] [info] [client 2001:6b0:b:2::27] SSL handshake
failed: HTTP spoken on HTTPS port; trying to send HTML error page
[Mon Jan 22 01:02:13 2007] [info] SSL Library Error: 336027804
error:1407609C:lib(20):func(118):reason(156)

[Mon Jan 22 01:02:14 2007] [info] [client 2001:6b0:b:2::27] Connection to child
2 established (server www.anst.uu.se:443)
[Mon Jan 22 01:02:14 2007] [info] Seeding PRNG with 136 bytes of entropy
[Mon Jan 22 01:02:14 2007] [info] [client 2001:6b0:b:2::27] SSL handshake
failed: HTTP spoken on HTTPS port; trying to send HTML error page
[Mon Jan 22 01:02:14 2007] [info] SSL Library Error: 336027804
error:1407609C:lib(20):func(118):reason(156)
--->8---

...where the server appears to connect to its own IPv6 address and apparently
attempts to speak HTTP to the HTTPS port.

The access log shows:

---8<---
2001:6b0:b:2::27 - - [22/Jan/2007:01:02:12 +0100] "GET /" 400 571 "-" "-" "-"
2001:6b0:b:2::27 - - [22/Jan/2007:01:02:13 +0100] "GET /" 400 571 "-" "-" "-"
2001:6b0:b:2::27 - - [22/Jan/2007:01:02:14 +0100] "GET /" 400 571 "-" "-" "-"
2001:6b0:b:2::27 - - [22/Jan/2007:01:02:15 +0100] "GET /" 400 571 "-" "-" "-"
2001:6b0:b:2::27 - - [22/Jan/2007:01:02:16 +0100] "GET /" 400 571 "-" "-" "-"
2001:6b0:b:2::27 - - [22/Jan/2007:01:02:17 +0100] "GET /" 400 571 "-" "-" "-"
2001:6b0:b:2::27 - - [22/Jan/2007:01:02:18 +0100] "GET /" 400 571 "-" "-" "-"
2001:6b0:b:2::27 - - [22/Jan/2007:01:02:19 +0100] "GET /" 400 571 "-" "-" "-"
2001:6b0:b:2::27 - - [22/Jan/2007:01:02:21 +0100] "GET /" 400 571 "-" "-" "-"
2001:6b0:b:2::27 - - [22/Jan/2007:01:02:22 +0100] "GET /" 400 571 "-" "-" "-"
2001:6b0:b:2::27 - - [22/Jan/2007:01:02:23 +0100] "GET /" 400 571 "-" "-" "-"
2001:6b0:b:2::27 - - [22/Jan/2007:09:46:32 +0100] "GET /" 400 571 "-" "-" "-"
--->8---

On a busy server, I get a lot of these after reloading, restarting or starting
the server, but also during normal operation. And they usually come in "chunks"
like this.

What could be the reason for this?

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message