httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41344] New: - Integrade apache2.2.x +php4.4.4(or php5.2.0) to embedded system get exit signal Segmentation fault (11)
Date Thu, 11 Jan 2007 01:39:16 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41344>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41344

           Summary: Integrade apache2.2.x +php4.4.4(or php5.2.0) to embedded
                    system get exit signal Segmentation fault (11)
           Product: Apache httpd-2
           Version: 2.2.3
          Platform: Other
        OS/Version: other
            Status: NEW
          Severity: critical
          Priority: P2
         Component: All
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: always0806@gmail.com


I am a embedded system engenier 
I try to porting apache2+php to our embedded system (arm9 linux kernel 2.6.15.7)
I cross compiling all in x86-linux system and tftp to embedded system running
cross compiling enviroment gcc-3.4.2-glibc-2.3.3
I cross compiling expat-1.95.8 apr-1.2.7 apr-util-1.2.7 pcre-5.0
and cross compiling apache2.2.0 2.2.3 2.2.4 with apr-1.2.7 apr-util-1.2.7(needed
expat) pcre-5.0
and cross compiling PHP4.4.4 with a normal compilng apache2
If I don't add php module apache2 running well
but when I add php moduel always get child pid xxx exit signal Segmentation
fault (11) when I open any url(exist or none exist url same result)
[Thu Jan 01 00:31:50 1970] [notice] Apache/2.2.0 (Unix) PHP/4.4.4 configured --
resuming normal operations
[Thu Jan 01 00:31:54 1970] [notice] child pid 242 exit signal Segmentation fault
(11)
[Thu Jan 01 00:31:58 1970] [notice] child pid 244 exit signal Segmentation fault
(11)


and then I try to cross compiling other apache2 version 2.0.59 with apr-0.9.13
apr-util-0.9.13(needed expat)
and cross compiling PHP4.4.4 with a normal compilng apache2
I can running apache2+php well


I don't know where is the problem. I use same setting to apache2.2.3+php4.4.4(or
php5.2.0)
alwys get child pid xxx exit signal Segmentation fault (11) when I open any url
is php cross compiling intergrade to apache2.2.X problem or apache2.2.X have
some problem?

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message