httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 41325] New: - Apache (59) hangs (outage) randomly
Date Tue, 09 Jan 2007 06:15:27 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=41325>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=41325

           Summary: Apache (59) hangs (outage) randomly
           Product: Apache httpd-2
           Version: 2.0.59
          Platform: Other
        OS/Version: Linux
            Status: NEW
          Severity: critical
          Priority: P4
         Component: mod_proxy
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: saijaiganesh@gmail.com


We are using Apache 59 (RHEL 3, Worker) as a forward proxy.
We have a traffic of approx 20 Mbps on this machine (dual CPU with HT enabled).
Resource utilization is very good (44-49 MB or RAM per httpd process and 10% of
CPU utilization)
We notice that Apache stops responding all of a sudden and will work only if we
restart it!
There is no entries in the error log (between the hang and the restart)that
might indicate an issue with Apache. 
Note: the outage occurred at 16:40 hrs approx

<error log snip>
[Mon Jan 08 16:08:13 2007] [error] [client 80.127.52.177] proxy: error reading
status line from remote server 85.17.63.102, referer: http://pwnots.hyves.nl/
[Mon Jan 08 16:08:13 2007] [error] [client 80.127.52.177] proxy: Error reading
from remote server returned by
http://85.17.63.102/hasmessage.js?digest=aGVzbGFiXzExNjgyNzU5MTVf1ktM1m3qEEh3avmnwVBnmw%3D%3D&noCache=5734566726&show=normal&status=online&changeStatus=false,
referer: http://pwnots.hyves.nl/
[Mon Jan 08 16:08:26 2007] [error] [client 82.92.46.149] proxy: error reading
status line from remote server 85.17.63.102, referer:
http://rianne135.hyves.nl/vrienden/
[Mon Jan 08 16:08:26 2007] [error] [client 82.92.46.149] proxy: Error reading
from remote server returned by
http://85.17.63.102/hasmessage.js?digest=amFubmVrZXNjaHJldWRlcnNfMTE2ODI3NTkzM18eH8Ve1Bd7NIFiBHv517nY&noCache=5079609824&show=normal&status=online&changeStatus=false,
referer: http://rianne135.hyves.nl/vrienden/
[Mon Jan 08 16:39:28 2007] [warn] child process 6220 still did not exit, sending
a SIGTERM
[Mon Jan 08 16:39:28 2007] [warn] child process 6728 still did not exit, sending
a SIGTERM
[Mon Jan 08 16:39:28 2007] [warn] child process 6217 still did not exit, sending
a SIGTERM
[Mon Jan 08 16:39:28 2007] [warn] child process 6218 still did not exit, sending
a SIGTERM
[Mon Jan 08 16:39:28 2007] [warn] child process 6550 still did not exit, sending
a SIGTERM

<error log snip>

This is the second such outage that we noticed in a week.

Httpd conf has the following entries

<IfModule worker.c>
ServerLimit         18
StartServers        10
ThreadsPerChild     50
MaxClients          900
MinSpareThreads     100
MaxSpareThreads     900
MaxRequestsPerChild 2000
</IfModule>

and 
KeepAlive Off

When the outage occurred we could not access the /server-status page to see what
Apache is doing.
Also here are some additional (at the time of hanging)info
# ps aux | grep httpd
root      7645  0.0  0.2 284776 12068 ?      S    Jan02   0:29
/usr/local/apache59/bin/httpd -k start
nobody    7648  0.0  0.2 284544 11840 ?      S    Jan02   0:00
/usr/local/apache59/bin/httpd -k start
nobody    1759  0.2  1.0 607320 44420 ?      S    15:32   0:08
/usr/local/apache59/bin/httpd -k start
nobody    6215  0.0  0.9 546736 37124 ?      S    16:00   0:02
/usr/local/apache59/bin/httpd -k start
nobody    6217  0.0  0.9 546736 37144 ?      S    16:00   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6218  0.0  0.9 554992 37480 ?      S    16:00   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6220  0.0  0.9 545704 37072 ?      S    16:00   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6389  0.0  0.9 546736 37132 ?      S    16:03   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6416  0.0  0.9 546736 37144 ?      S    16:03   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6417  0.0  0.9 546736 37156 ?      S    16:03   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6466  0.0  0.9 546736 37116 ?      S    16:03   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6467  0.0  0.9 545712 37116 ?      S    16:03   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6468  0.0  0.9 546736 37144 ?      S    16:03   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6469  0.0  0.9 545712 37104 ?      S    16:03   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6530  0.1  0.9 545712 37116 ?      S    16:03   0:02
/usr/local/apache59/bin/httpd -k start
nobody    6534  0.0  0.9 546736 37232 ?      S    16:03   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6535  0.0  0.9 546736 37120 ?      S    16:03   0:01
/usr/local/apache59/bin/httpd -k start
nobody    6543  0.1  0.9 546736 37136 ?      S    16:03   0:02
/usr/local/apache59/bin/httpd -k start
nobody    6550  0.1  0.9 546736 37152 ?      S    16:03   0:02
/usr/local/apache59/bin/httpd -k start
nobody    6728  0.0  0.9 546736 37148 ?      S    16:03   0:00
/usr/local/apache59/bin/httpd -k start
nobody    6753  0.0  0.9 546736 37156 ?      S    16:03   0:01
/usr/local/apache59/bin/httpd -k start


Any help will be highly appreciated

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message