httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 29744] - CONNECT does not work over existing SSL connection
Date Thu, 11 Jan 2007 04:22:32 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=29744>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=29744





------- Additional Comments From emmanuel.e@gmx.net  2007-01-10 20:22 -------
maybe you could check out the 2.0.5x version. at least it works there.

(In reply to comment #29)
> I've downloaded recently the source code from apache 2.2.0 but the patch won't 
> apply... Which other patches are required ?
> 
> I'm running a 2.2.3 apache server and none of the patches here seem to apply. 
> This is why I'm now trying with the 2.2.0 official distrib, but I get more or 
> less the same result.
> 
> I tried to debug the code myself but I barely know the apache API. I'm 
> wondering what the backconn socket in the patch represent, where does it come 
> from ? there are references to some c-> structure but I don't have any c 
> variable in my https 2.2.0 original code ??? then there is this "packet 
> brigade" stuff that is used to copy blocks but I dont have it in the original 
> source eihter ?? then finally there are thes input/ouput filters.. ???
> 
> can anyone point my out of this stuff ? or just mail me a plain patched 
> mod_proxy_connect.c file from the 2.2.0 distrib so I can start from something 
> concrete instead of some patch work that makes no sense to me so far ?
> 
> why isn't the 2220 patch working on the httpd2.2.0 original source code ? 
> applying a patch is as easy as patch -u -p0 < patch_file... damn what could I 
> miss ???
> 
> many many many thx in advance for your tips/hints help.
> 
> (In reply to comment #27)
> > Created an attachment (id=18222)
 --> (http://issues.apache.org/bugzilla/attachment.cgi?id=18222&action=view) [edit]
[edit]
> > Fixed patch with read loops and updated to 2.2.0
> > This is a new version of the patch to use the filter I/O in proxy_connect. 
> Some
> > modules don't return everything with a single ap_get_brigade() call, so this
> > version loops until there is no data pending. The filter chains in the 
> request
> > are now set to the ones from the connection instead of NULL. I also have
> > updated to 2.2.0 and changed some log messages.
> 
> 



-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message