httpd-bugs mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From bugzi...@apache.org
Subject DO NOT REPLY [Bug 40069] New: - Crash in apr_pool_destroy
Date Tue, 18 Jul 2006 21:32:53 GMT
DO NOT REPLY TO THIS EMAIL, BUT PLEASE POST YOUR BUG·
RELATED COMMENTS THROUGH THE WEB INTERFACE AVAILABLE AT
<http://issues.apache.org/bugzilla/show_bug.cgi?id=40069>.
ANY REPLY MADE TO THIS MESSAGE WILL NOT BE COLLECTED AND·
INSERTED IN THE BUG DATABASE.

http://issues.apache.org/bugzilla/show_bug.cgi?id=40069

           Summary: Crash in apr_pool_destroy
           Product: Apache httpd-2
           Version: 2.2.2
          Platform: PC
        OS/Version: Windows XP
            Status: NEW
          Severity: major
          Priority: P2
         Component: Event MPM
        AssignedTo: bugs@httpd.apache.org
        ReportedBy: artk@congruent.com


I'm moving an existing IIS ISAPI extension to Apache.   When I connect to 
Apache using localhost, the second attempt crashes as follows:

memory\unix\apr_pools.c
apr_pool_destroy(apr_pool_t * 0x0091a9c0) line 737 + 5 bytes
 
parent->pool = 1

if ((mutex = apr_allocator_mutex_get(pool->parent->allocator)) != NULL)
            apr_thread_mutex_lock(mutex);


This does not occur if I connect using the hostname.

-- 
Configure bugmail: http://issues.apache.org/bugzilla/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug, or are watching the assignee.

---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@httpd.apache.org
For additional commands, e-mail: bugs-help@httpd.apache.org


Mime
View raw message